Homematic virtual Interface auf Raspberry PI installieren

Der HomeMatic virtual Interface Layer dient dazu, Systemfremde Komponenten sowie Onlinedienste wie z.B. Wetterdienste in die HomeMatic einzubinden.
Diese Software wird auf einem Raspberry Pi* installiert und mit der HomeMatic CCU* verknüpft.
Ich möchte den HomeMatic virtual Interface Layer zunächst für folgende Anwendungen nutzen.

Für die Einbindung des Logitech Harmony Hub* und somit für die Steuerung des Fernsehers der Heimkinoanlage etc.Für die Einbindung von online Wetterdaten Und später auch mal für die Nanoleaf Aurora* Leuchten

Zu allen Themen werde ich später noch eigene Videos machen.
In diesem Beitrag soll es um die Installation der Software und um die Einbindung in die HomeMatic gehen.

https://youtu.be/zmNe8sL3yc4

Hardware und Software Links

Raspberry Pi 3B+ Set mit Netzteil, Gehäuse und 16GB SD-Karte *
HomeMatic CCU3 *
Logitech Harmony Hub *
Nanoleaf Aurora Light Panels *

HomeMatic virtual Interface Download
Raspbian Download

Alle Kommentare und Bewertungen geben meine persönliche Meinung und Erfahrungen mit dem im Beitrag angesprochenen Produkten wieder. 

*Affiliate Links (Durch die Benutzung der Affiliate Links entstehen keine Zusatzkosten aber dieser Blog wird dadurch unterstützt)
Danke für die Unterstützung!

Die Produkte habe ich selbst gekauft und bezahlt. Es wurde mir weder vom Hersteller noch durch einen Händler ein Produkt zur Verfügung gestellt. Als Amazon-Partner verdiene ich an qualifizierten Verkäufen. Ich empfehle nur Produkte von denen ich selbst überzeugt bin. Ich übernehme keine Haftung für bestimmte Funktionen oder Schäden die durch das nachbauen dieser Anleitung entstehen.


3 Gedanken zu „Homematic virtual Interface auf Raspberry PI installieren“

  1. Hallo,

    ein wirklich tolles und hilfreiches Video.
    Leider bin auch ich nicht ans Ziel gelangt, bei mir zeichnet sich ein ähnliches Problem ab.

    Ich habe HVL auf einem Raspberry installiert, soweit so gut.
    Beim verbinden mit meiner CCU bekomme ich die selbe Meldung :
    CCU IP: „IP_Adresse“ no response

    Ich habe dann erfolglos Deine Tipps überprüft, habe zur Zeit alle Port und Firewall Einstellungen offen und auf Vollzugriff.

    Nachdem ich die HVL Software über die CCU installiert habe und dort die IP des HVL bekannt gegeben habe, bekomme ich nun die Melung:

    CCU IP: „IP_Adresse“ no response
    und darunter:

    1 active Connections („IP_Adresse“:1999/ | Last Message )

    Ich habe am Wochenende diverse Neustarts der CCU und des Raspberry hinter mir und bin ratlos.

    Plugins werden in der CCU so noch nicht erkannt.

    Bin für jeden Tipp dankbar,

    CCU3 Software: 3.47.10
    HVL 0.2.68

    Vielen Dank!!!

  2. Tolles Video! Tolle Anleitung!

    Leider komme ich nur bis zu dem Punkt bei dem die IP der CCU3 in der Weboberfläche des HVI auf dem PI eingetragen werden muss. Sobald ich die IP eintrage, kommt nur die Info …reboot…

    Wenn ich die Seite nochmal aufrufe (IP:8182) dann kommt nur „CCU IP: 192.168.0.102 no response“

    Eine Idee?

    CCU3 mit RaspPi3 für HVI

    Grüße!

    1. Hallo Benjamin,

      Spontan fallen mir 3 Sachen ein die du kontrollieren könntest.

      1. Hast du beide Teilnehmer neu gestartet, CCU und den Raspberry PI auf dem der HvIL läuft.

      2. Schau mal auf der CCU ob das HvIL Addon installiert wurde.
      Einstellungen > Systemsteuerung > Zusatzsoftware
      Da müsste ein Plugin installiert sein.

      3. Die Firewall Einstellungen der CCU kontrollieren.

      Die Einstellungen findest du unter:

      Einstellungen > Systemsteuerung > Firewall konfigurieren

      Das sollte alles auf „Eingeschränkt“ stehen denn dann ist ein Lokaler Zugriff möglich.
      sollte da irgendwo „Kein Zugriff“ stehen dann ändern und erneut versuchen das CCU Plugin vom HvIL aus zu installieren.
      So wie im Video ab Minute 12:25 zu sehen.

      Wichtig ist auch der Block
      „IP Adressen für den eingeschränkten Zugriff“

      Das sollte bei dir etwa so aussehen! Da kannst du auch explizit die IP des Raspberry PI auf dem der HvIL läuft eintragen.
      z.B. so:
      192.168.0.1;
      192.168.0.0/16;
      IPdeinesHvIL;
      fc00::/7;
      fe00::/10

      IPdeinesHvIL bitte durch die IP deines Raspberry PI ersetzen.

      Das ; am Ende jeder Zeile bzw. zwischen den einzelnen Einträgen nicht vergessen außer am Ende der letzten Zeile!

      Du kannst auch versuchsweise alles mal auf Vollzugriff stellen. Das sollte aber keine Dauerlösung sein. Aber wenn es dann geht kannst du dir sicher sein dass es an den Firewall Einstellungen liegt.

      Nach der Freigabe noch mal über den HvIL versuchen das Plugin über die HvIL Oberfläche zu installieren und eine Verbindung herzustellen.
      Neustart beider Geräte nicht vergessen!

Schreibe einen Kommentar

Deine E-Mail-Adresse wird nicht veröffentlicht.